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RELEASE NOTES 
Software version 4.1.1 – November 20th, 2025. 

 
We are pleased to announce the release of PinPoint version 4.1.1. 

 

 

 

This document contains important information about the desktop software PinPoint version 

4.1.1. 

 

You can now download the new software installer from myWorld Customer Portal: 

https://myworld-portal.leica-geosystems.com 

 

and PinPoint website: 

https://leica-geosystems.com/products/laser-scanners/software/pinpoint 

  

https://myworld-portal.leica-geosystems.com/
https://leica-geosystems.com/products/laser-scanners/software/pinpoint
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WHAT’S NEW 

 
Version 4.1.1 

• Fixed connection issue of BLK2GO when path file contains special characters (not 

part of the ASCII alphabet). 

• Fixed BLK2GO issue that would import the scans incomplete. 

 

Version 4.1 released on 13.11.2025 

Version 4.1 of PinPoint supports the following features: 

• New support of BLK2GO and BLK ARC scanners, point and image data 

o Direct connection to BLK2GO and BLK ARC 

o BLK ARC static scan support 

o Trajectory split 

o Visual blend of pano-images and point cloud 

o Detail camera image support for BLK2GO and BLK ARC 

o User requested panoramic image support for BLK2GO and BLK ARC 

• New support of Jobs and Geotags from Cyclone Field 360 for BLK and RTC360 

scanners 

• New support of external spherical images for panorama creation, registration and 

colorization 

• Improved Colorizer 

• New Language support: Korean (KO) 

• New Navigation with gizmo 

• Render Option to show intensities of point cloud 

• Extended support of Leica format files 

• Revised CLM Integration to use established floating license workflows 

 

A detailed description of the features and improvements follows. 
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PinPoint v4.1 reinforces the value of being a reality capture software by bringing the full 

support of scanners and scans from the BLK2GO and BLK ARC to provide a complete 

experience with specialized functionalities. 

• Direct Connection to BLK2GO and BLK ARC scanners  

Now, you can directly connect to your BLK2GO and BLK ARC scanner by means 

of USB-C Cable or Wi-Fi using PinPoint BLK Transfer Tool or Registration Tool. 

From PinPoint BLK Transfer Tool: 

 

 
 

The PinPoint BLK Transfer Tool can connect and download scans. By default, all 

the scans are checked to be imported. In addition, BLK Transfer Tool keeps 
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memory of scans that have been already downloaded; so, when connecting a later 

time to the scanner, the scans will be automatically unticked. 

The download from any BLK scanners (dynamic or static) results in .saf file that 

contains jobs, geotags (and VIS info in case of BLK360 only) and information 

about the capturing scanner of each selected scan. For each scan, a .saf file is 

stored on your PC and can be used as back-up file of your scan. 

Later, the .saf file can be imported in Registration Tool to generate a 3D scene, 

using File→ Import→ PinPoint BLK Transfer Tool: 

 

 

 

Direct connection to scanner can be achieved also in Registration Tool by using 

File → Import → BLK → Select from the list your scanner: 

 

 
 

If you choose to import .saf files in the Registration Tool you are prompted to the 

PinPoint BLK Transfer Tool Import Settings: 
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If you choose to import .b2g files in the Registration Tool, you are prompted to 

the B2G Import Settings: 

 

 
 

Instead, if you choose to direct connect to your BLK2GO or BLK ARC scanner 

using the Registration Tool, you will be prompted to this import window, in this 

case direct connection to BLK2GO: 
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By default, all the jobs and scans stored into the scanner are selected to be 

imported. On this window, you can unselect/select, delete scans and set the 

import settings. 

The import options of PinPoint BLK Transfer Tool Import Settings, B2G Import 

Settings and direct connection are the same. These are settings about import 

images to create panoramic images at the waypoints and colorize the pointcloud. 

If Import with images is ticked, pointcloud can be colorized by Quick or Optimal 

colorizer otherwise intensity values are used. The Quick colorizer option is faster 

circa x2 times than the Optimal colorizer. The waypoints can be created at an 

even distance that can be specified. Re-SLAM computation can be skipped if the 

file is already processed. 

After importing, you will get notified about the result as an example here: 

 

 
 

• Static scan support for BLK ARC data 

PinPoint can distinguish Dynamic from Static poses within a scan from BLK ARC 

data. BLK ARC scans are grouped in the navigation panel to have layers for any 

of the collected static scans and one unique layer for the dynamic scan. Geotags 

are associated according to the scans they belong to. 
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• Trajectory split 

BLK mobile scanner data can be split according to the selection. The benefit is to 

be able to trim pointcloud based on area of interest (i.e. multi-store building) or for 

excluding SLAM drift. It is applicable to dynamic scan layers only. 

Select the scan from the navigation panel, right click and select Split Trajectory. 

 

 
 

The split is possible by moving the small red sphere along the trajectory colored 

by timestamp. 
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Follow instructions at the bottom left and then confirm your selection with the 

green check to validate. 

 

 
 

Finally, two new additional layers will be created as result of the split. Both new 

layers can be visualized, moved and exported. 
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• Visual blend of pano-images and point cloud 

Upon import, even distributed waypoints are set. In the 3D scene, these waypoints 

can be accessed by right clicking on the spheres; if you hold right click and move 

the mouse, you see nice transition between the pano-image on the waypoint and 

the point cloud. 

 
 

• Detail camera image support for BLK2GO and BLK ARC 

Each detail image captured during the scan via push button or field app is shown 

in the navigation panel as an item belonging to the scan. It can be accessed by 

right clicking. The detailed camera images are not rectified. 

 

 
 

• User requested panoramic image support for BLK2GO and BLK ARC 

Each user requested panoramic image captured during the scan via push button 

or field app is imported by creating a waypoint in the 3D scene. 

 

• Jobs and Geotags from Cyclone Field 360 for BLK and RTC360 scanners 

Jobs and geotags are important pieces of information that enriches the capture of the 

scene with some context. PinPoint is now capable of making use of this information for 

any BLK scanner supported and RTC360 data, keeping the same structure and 

information set during the collection of the data. 
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The job structure from the field app is preserved in your PinPoint project to better handle 

your scans and information. In the navigation panel, job is the container of all the scans 

belonging to it. 

The geotags captured using field apps attached to 3D points in 3D scene are visualized 

by means of a pin. The geotags is accessible by right clicking in the scene or by selecting 

the layer in the navigation panel and then right clicking to open it. Hovering on the geotag 

layer in the navigation panel shows timestamp information and notes. Depending on the 

file type, geotags are shown using the default app assigned by the windows systems; for 

instance, image file opens by Image viewer, .pdf file opens using Foxit Reader, etc.… 

Geotags are not exported from the Registration Tool. 

 

 
 

 

• Render Option to show Intensities of point cloud 

PinPoint Registration Tool and Modeler can show the pointcloud by intensity. 

View→ Point Cloud Colors → Intensities or using the shortcut from keyboard pressing 

F4. 

 

• New Navigation in Registration Tool and Modeler 

The new navigation orientation gizmo helps the usability of the software and consists of: 



PINPOINT  
POINT CLOUD REGISTRATION AND MODELLING SOFTWARE 

 

 

 

• Home button 

• Cube with faces and arrow 

Every component can be accessed by right click of the mouse to navigate and apply the 

rotation/translation. 

  

 

• Language support extension 

PinPoint is now available in Korean (KO). 

 

• Revised CLM Integration 

The type of PinPoint license is Floating, and the status is Valid and not anymore 

Borrowed, as in the following image: 
 

 
 

In case of CLM version < 2.26, the status of the license is still shown as Borrowed. You 

need to upgrade to 2.26 and restart the application. 

 

• Extended logging of PinPoint and CLM 

From Help → Show Logs → Download Logs, PinPoint + CLM logs are stored together for 

better customer support experience in case of technical issues. 
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REGISTRATION TOOL 
WHAT’S NEW 

• New Colorizer: Best visual performance using the “Optimal” settings (processing time = 

5x scan time); “Quick” settings with comparable visual quality, but 3x faster (processing 

time = 1.4x scan time). 

• New revised UI of the Registration Tool that brings additional functionalities and usability 

to the software. 

Under Register section Snap and Panoramic buttons are added. 

 

 
 

Snap button initiates the registration of any scans. 

 

 
 

Pressing it will enable to Move scans in the navigation panel and use the commands 

Snap Scans, Snap Group, Reset Transformation and Statistics at the top right in the 3D 

scene, as on the image below: 
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• New support for importing, registering, editing, and using external spherical panoramas 

(e.g. Insta360) for point cloud colorization and registration. 

 

 
 

o External spherical panoramas can be imported to Registration Tool 

o Automatic registration based on image features 

 

.      

 

         (switching between panorama image on the left and point cloud on the right) 

o New interface for easy manual registration based on point correspondence 

o Panoramas can be used as input for point cloud and mesh colorization 

 

• Under Control section, an easier way of navigating between scans or panorama images 

is made available by using the arrow left and right to go the previous or following 

scan/image respectively. 

 

 
 

• Extended support of Leica format files in Registration Tool. 

Knowing the extended use of .blk format files downloaded from BLK Data Manager app 

or Webpage, PinPoint is now supporting this format file to enable new workflows of the 

BLK360 scanner family. The format file .blk can be imported using File → Import → BLK 

→ .blk file 
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IMPROVEMENTS & BUG FIXES 

• Improved memory usage and computation time of the colorizer 

• Improved importer and renderer performance 

 

 

MODELER 

IMPROVEMENTS & BUG FIXES 

• Fixed handling of long coordinate system 

• Improved coordinate precision for geo-referenced exports (e.g., DXF files) 

 

 

SOFTWARE COMPATIBILITY 
Compatibility with: 

• Client License Manager (CLM) version 2.26.0 or higher 

• Leica BLK360 / BLK360 SE firmware 3.0.0 or higher 

• Leica BLK2GO firmware 4.3.0 or higher 

• Leica BLK360 G1 firmware 2.1.1 

• Leica RTC360 firmware 7.0 or higher 

• Cyclone Field 360 App 6.1 or higher 

 

 
SYSTEM REQUIREMENTS 
Operating System: 

• Microsoft® Windows® 10 (64-bit) or higher 

 

Minimum Hardware Specification: 

• CPU: 6 cores: Intel i5-8th Gen, AMD Ryzen 5 2600 or higher 
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• RAM: 16GB 

• GPU: NVIDIA GTX 1660 (6GB VRAM), OpenGL® 4.3 or higher 

• Storage: 256GB SSD with at least 1GB of space for installation 

Recommended Hardware Specification: 

• CPU: 12 cores: Intel i7-12th Gen 

• RAM: 64GB 

• GPU: NVIDIA RTX 3070 (8GB VRAM), OpenGL® 4.3 or higher 

• Storage: 1TB NVMe SSD with at least 1GB of space for installation 

 

 

USAGE 
Data import formats: e57, blk, b2g, rtc360, pts, ptx, xyz, rcp, saf, srf, smf 

Data export formats: e57, pts, ptx, ply, rcp, jpg, png, dxf, obj, off, stl, svg, saf 

 

 

RECOMMENDATIONS 
You must have administrative privileges on your computer to correctly install and license 

PinPoint. 

To ensure optimal performance, it is required to configure the graphics card to high 

performance for each PinPoint module. 

Please refer to the PinPoint User Manual (User Manual). 

 

 

CONTACT SUPPORT 
In need of help? Get in contact with the technical support team of your region using the 

contact support form available at BLK Support website here. 
For more information about PinPoint please refer to the User Manual (User Manual) and the 

PinPoint website: https://leica-geosystems.com/products/laser-scanners/software/pinpoint. 

https://dl.blk.hexagon.com/pinpoint/attachments/user_manual/pinpoint/4.0.0/en/quick-start-guide/index.html
https://shop.leica-geosystems.com/global/leica-blk/support/contact-support
https://dl.blk.hexagon.com/pinpoint/attachments/user_manual/pinpoint/4.0.0/en/quick-start-guide/index.html
https://leica-geosystems.com/products/laser-scanners/software/pinpoint

